diff pyproject.toml @ 24:e0bf84641c09

Move to using Hatch and VCS-based version.
author Paul Fisher <paul@pfish.zone>
date Sun, 02 Mar 2025 19:16:10 -0500
parents
children 2ec668fdec88
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/pyproject.toml	Sun Mar 02 19:16:10 2025 -0500
@@ -0,0 +1,29 @@
+[build-system]
+requires = ["hatchling", "hatch-vcs"]
+build-backend = "hatchling.build"
+
+[project]
+name = "weatherlog"
+dynamic = ["version"]
+license = ""
+requires-python = ">=3.7"
+dependencies = [
+    "attrs",
+    "pymongo",
+    "pytz",
+    "requests",
+    "RPi.bme280",
+    "smbus2",
+    "toml",
+]
+
+[project.scripts]
+weatherlogd = "weatherlog.daemon:main"
+
+[tool.hatch.version]
+source = "vcs"
+
+[tool.hatch.build.targets.sdist]
+include = [
+    "/weatherlog",
+]