diff setup.py @ 17:39c0686e6765

daemon: Change to executing from a config file. This updates daemon.py to execute based on a config file, rather than needing manual configuration. It also instructs setup.py to create an entry point for the new daemon.py main function. Configuration is specified in a TOML file whose format is documented, kind of, in the parse_config function.
author Paul Fisher <paul@pfish.zone>
date Thu, 17 Oct 2019 22:28:12 -0400
parents b5625b531d2d
children 9daa281d996b
line wrap: on
line diff
--- a/setup.py	Thu Oct 17 22:19:33 2019 -0400
+++ b/setup.py	Thu Oct 17 22:28:12 2019 -0400
@@ -2,7 +2,7 @@
 
 setuptools.setup(
     name='weatherlog',
-    version='0.1.0',
+    version='0.2.0',
     packages=setuptools.find_packages(),
     python_requires='>=3.7',
     install_requires=[
@@ -14,6 +14,12 @@
         'requests',
         'RPi.bme280',
         'smbus2',
+        'toml',
     ],
     setup_requires=['wheel'],
+    entry_points={
+        'console_scripts': [
+            'weatherlogd = weatherlog.daemon:main',
+        ]
+    }
 )