diff pyproject.toml @ 38:d5a18ecebf47

Convert to Hatch pyproject.toml.
author Paul Fisher <paul@pfish.zone>
date Tue, 01 Apr 2025 15:46:16 -0400
parents
children b77c8e7d2742
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/pyproject.toml	Tue Apr 01 15:46:16 2025 -0400
@@ -0,0 +1,23 @@
+[build-system]
+requires = ["hatchling", "hatch-vcs"]
+build-backend = "hatchling.build"
+
+[project]
+name = "weather-server"
+dynamic = ["version"]
+requires-python = ">=3.7"
+dependencies = [
+    "attrs",
+    "flask",
+    "flup",
+    "pymongo",
+    "pytz",
+]
+
+[tool.hatch.version]
+source = "vcs"
+
+[tool.hatch.build.targets.sdist]
+include = [
+    "/weather_server",
+]