diff Cargo.toml @ 21:f6334887e3c8

Support `tokio` 1.0 Tokio 1.0 was already out for a while and this adds the missing support for it. Deprecation of 0.2 and 0.3 is planned but they are staying for now.
author Martin Habovstiak <martin.habovstiak@gmail.com>
date Sat, 13 Jul 2024 15:09:13 +0200
parents 2b78a483f84b
children f33e2c048104
line wrap: on
line diff
--- a/Cargo.toml	Sat Jul 13 14:19:29 2024 +0200
+++ b/Cargo.toml	Sat Jul 13 15:09:13 2024 +0200
@@ -30,6 +30,7 @@
 serde_str_helpers = { version = "0.1.2", optional = true }
 parse_arg = { version = "0.1.4", optional = true }
 lazy_static = "1.4.0"
+tokio = { package = "tokio", version = "1.0.0", optional = true, features = ["net"] }
 tokio_0_2 = { package = "tokio", version = "0.2", optional = true, features = ["tcp", "dns"] }
 tokio_0_3 = { package = "tokio", version = "0.3", optional = true, features = ["net"] }
 async-std = { version = "1.7.0", optional = true }