diff Cargo.toml @ 4:66c0e10c89fc

Support resolving hostnames Until now the crate supported only IP addresses and systemd sockets. This was troublesome because it prevented the popular `localhost:1234` format. This commit changes the behavior so that if parsing of `std::net::SocketAddr` fails it attempts to parse it as `hostname:port`. `bind_*()` methods were also modified to be async because of this.
author Martin Habovstiak <martin.habovstiak@gmail.com>
date Fri, 27 Nov 2020 15:05:19 +0100
parents a65053246c29
children a7893294e9b2
line wrap: on
line diff
--- a/Cargo.toml	Fri Nov 27 12:56:37 2020 +0100
+++ b/Cargo.toml	Fri Nov 27 15:05:19 2020 +0100
@@ -16,6 +16,6 @@
 parse_arg = { version = "0.1.4", optional = true }
 libsystemd = "0.2.1"
 lazy_static = "1.4.0"
-tokio_0_2 = { package = "tokio", version = "0.2", optional = true, features = ["tcp"] }
+tokio_0_2 = { package = "tokio", version = "0.2", optional = true, features = ["tcp", "dns"] }
 tokio_0_3 = { package = "tokio", version = "0.3", optional = true, features = ["net"] }
 async-std = { version = "1.7.0", optional = true }