diff Cargo.toml @ 24:1941e9d9819c

Fix unsound manipulation of env vars Modifying env vars in multi-threaded process is unsound but this crate was neither checking the number of threads nor mark its functions as `unsafe`. This change fixes it by both adding a check and adding an `unsafe` function that can bypass that check if needed.
author Martin Habovstiak <martin.habovstiak@gmail.com>
date Fri, 28 Feb 2025 13:52:31 +0100
parents 729392c49b46
children 8e20daee41ed
line wrap: on
line diff
--- a/Cargo.toml	Sat Jul 13 15:14:32 2024 +0200
+++ b/Cargo.toml	Fri Feb 28 13:52:31 2025 +0100
@@ -30,7 +30,7 @@
 serde_crate = { package = "serde", version = "1.0.116", optional = true, features = ["derive"] }
 serde_str_helpers = { version = "0.1.2", optional = true }
 parse_arg = { version = "0.1.4", optional = true }
-lazy_static = "1.4.0"
+once_cell = "1.13.0"
 tokio = { package = "tokio", version = "1.0.0", optional = true, features = ["net"] }
 tokio_0_2 = { package = "tokio", version = "0.2", optional = true, features = ["tcp", "dns"] }
 tokio_0_3 = { package = "tokio", version = "0.3", optional = true, features = ["net"] }