diff Cargo.toml @ 56:daa2cde64601

Big big refactor. Probably should have been multiple changes. - Makes FFI safer by explicitly specifying c_int in calls. - Uses ToPrimitive/FromPrimitive to make this easier. - Pulls PamFlag variables into a bitflags! struct. - Pulls PamMessageStyle variables into an enum. - Renames ResultCode to ErrorCode. - Switches from PAM_SUCCESS to using a Result<(), ErrorCode>. - Uses thiserror to make ErrorCode into an Error. - Gets rid of pam_try! because now we have Results. - Expands some names (e.g. Conv to Conversation). - Adds more doc comments. - Returns passwords as a SecureString, to avoid unnecessarily keeping it around in memory.
author Paul Fisher <paul@pfish.zone>
date Sun, 04 May 2025 02:56:55 -0400
parents 676675c3d434
children 2a5c83d04b93
line wrap: on
line diff
--- a/Cargo.toml	Sun May 04 00:58:04 2025 -0400
+++ b/Cargo.toml	Sun May 04 02:56:55 2025 -0400
@@ -10,5 +10,9 @@
 edition = "2021"
 
 [dependencies]
+bitflags = "2.9.0"
 libc = "0.2.97"
+num-derive = "0.4.2"
+num-traits = "0.2.19"
+secure-string = "0.3.0"
 thiserror = "2.0.12"